I cant discover Linux cant discover Linux machines with System Center 2012 sp1.

If you have System Center 2012 Sp1 and you Install the Management packs for Linux discovery, you may find you cannot discover anything. I found this boiled down to a series of unfortunate events. In the case of a client, no discovery ever occurs. In the case of the server, no discovery is ever initiated. In fact, If you enable logging using (COPY /Y NUL %windir%\TEMP\EnableOpsMgrModuleLogging) from TechNet you will see that when you restart the System Center Management service, you don’t get any creation of log files. In this circumstance, It was necessary to query the SCOM database and we found that some failure was occurring involving tokens

[0]16276.16736::09/09/2013-15:12:16.524 [SecureStorageManager] [] [Verbose] :CSecureStorageManager::getAccountSid{SecureStorageManager_cpp5545}Got cached SID for SSID
[0]16276.16736::09/09/2013-15:12:16.525 [SecureStorageManager] [] [Warning] :CSecureStorageManager::getTokenForCredential{SecureStorageManager_cpp5407}Attempted to get token for a non-windows credential of type 3
[0]16276.16736::09/09/2013-15:12:16.525 [SecureStorageManager] [] [Error] :CSecureStorageManager::getAccountSid{SecureStorageManager_cpp5564}Unable to log on account : WINERROR=80FF006F
[0]16276.16736::09/09/2013-15:12:16.525 [ExecutionManager] [] [Error] :CTaskTracker::StartTask{TaskTracker_cpp849}GetAccountSid failed with code WINERROR=80FF006F.
[0]16276.16736::09/09/2013-15:12:16.525 [ExecutionManager] [] [Error] :CExecutionManagerInternal::ExecuteTask{ExecutionManager_cpp1231}StartTask failed with code WINERROR=80FF006F.
=====

 

So after consulting MS on the issue, there was an account created during an import of a Dell Management pack that was culpable (page 16 from the link below).  The name of the account is not specified in the solution and I could not narrow the large guide to a specific procedure in which this occurred (edit its on page 16). It is a SCOM profile ‘WS-Management Action Account’  If you have created any out of band accounts, in conjunction with the import of a management pack, this would be suspect, based on the experience. the Dell MP guide is located at the Dell FTP site

You may also have a certificate issue as well. It may be tempting to just use the user name and password during the discovery. You will need complete the Linux certificate process per the TechNet article for discovery to be successful. I hope this is helpful to someone

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s